[轉貼] php 5.2+ is required

 

將 CentOS 5.3 升級至 PHP 5.2 + Mysql 5.1

原出處:這裡

前幾天另一台電腦安裝好 CentOS 5.3,Apache 也安裝好了,正準備要使用 phpMyAdmin 來管理我的 MySQL 時,登入 phpMyAdmin 首頁時卻出現 『php 5.2+ is required』 的訊息。這..這是什麼碗糕啊??原來啊…CentOS 5.3 的 PHP 只有到 5.1.6 版,而沒有辦法支援新版的 phpMyAdmin。解決方式有:第一個就是安裝比較早版本的 phpMyAdmin,另一個就是把他的 PHP版本升級到5.2版吧!不然就是改用其他版本的 Linux。因為舊版的 phpMyAdmin 刪除資料庫時比較麻煩,所以這裏我選擇將 PHP 升級,現在就跟著我一起將你的 CentOS 升級到 PHP 5.2 吧!

1.安裝 epel / remi 套件資訊

# wget http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-4.noarch.rpm

# wget http://rpms.famillecollet.com/el5.i386/remi-release-5-7.el5.remi.noarch.rpm

# rpm -ihv *-release-5*.rpm

2.指定 remi 套件組,更新 PHP / Mysql

# yum –enablerepo=remi update php mysql

3.安裝完之後,記得重新啟動 httpd 與 mysqld 服務

# service httpd restart

# service mysqld restart

 

4.確認版本是否已升級

# php -v

PHP 5.2.10 (cli) (built: Aug  6 2009 13:00:59)

Copyright (c) 1997-2009 The PHP Group

Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

PHP 已升級至5.2.10版啦!

# mysql -u root -p

Enter password:

Welcome to the MySQL monitor.  Commands end with ; or g.

Your MySQL connection id is 4

Server version: 5.1.37 MySQL Community Server (GPL) by Remi

Type ‘help;’ or ‘h’ for help. Type ‘c’ to clear the current input statement.

mysql>

MySQL 也升級至5.1.37版囉!